Epic Maintenance

Incident Report for Houston Methodist

Resolved

Maintenance complete.
Posted Dec 09, 2023 - 04:10 CST

Identified

Epic cutover is happening at this time.
Posted Dec 09, 2023 - 02:10 CST
This incident affected: Houston Methodist Care (Epic and Interconnect).