DexCare impaired

Incident Report for Houston Methodist

Resolved

There was a broad internet outage including AWS this morning which impacted the DexCare platform between roughly 7:20 AM - 8:15 AM Pacific. We are getting information that the outage is over and validated that the platform is functioning normally. We will continue to monitor our systems. We will provide updates via StatusPage and e-mail if additional outages occur.
Posted Dec 15, 2021 - 10:39 CST

Investigating

We are currently investigating the incident, initial investigation points to major Internet outage.
Posted Dec 15, 2021 - 10:03 CST
This incident affected: Houston Methodist Care (Virtual Visits).