EPIC InterConnect Outage

Incident Report for Houston Methodist

Resolved

We are now able to connect
Posted Apr 21, 2022 - 17:13 CDT

Investigating

We have been unable to get a response from the Epic instance since 2:17pm PST.
Posted Apr 21, 2022 - 16:45 CDT
This incident affected: Houston Methodist Care (Epic and Interconnect).