EPIC Interconnection Outage

Incident Report for Houston Methodist

Resolved

HM Believes the issue has resolved. Pulling down to test.
Posted Sep 06, 2022 - 19:53 CDT

Investigating

We're contacting support team to resolve the issue.
Posted Sep 06, 2022 - 19:12 CDT
This incident affected: Houston Methodist Care (Epic and Interconnect, Virtual Visits).